Vlookup Fonksiyonu

Vlookup fonksiyonu Excel’de en çok kullanılan fonksiyonlardan birisidir. Bu fonksiyon bir listenin içerisinden belirli bir kritere göre veri çekmenize olanak sağlar.

Örneğin bir satış işlemine ait bir satış kodunuz var ise ve bu satışın hangi müşteriye yapıldığını bulmak isterseniz bunu nasıl yapabilirsiniz?

Eğer sadece bir müşteri ismini arıyorsanız basit bir filtre kullanarak aradığınız bilgiye ulaşabilirsiniz. Ancak eğer bir çok işlem kodunu müşteri adlarıyla eşleştirmek istiyorsanız, bu durumda daha güçlü bir araca ihtiyacınız var demektir. Vlookup fonksiyonu tam da burada devreye girmekte.

Örneğimize bakarsak:

Elimizdeki veri seti aşağıdaki görüldüğü gibi 2012 yılına ait satışların bir listesidir.

Elimizde satış işlem bir no (TR20127973) var ve 1000 satırlık bu listede bu satışa karşılık gelen müşteri kodunu bulmak istiyoruz. Bu iş için Vlookup fonksiyonu kullanacağız.

Bunun için müşteri kodunun gösterilmesini istediğiniz hücreyi seçin ve aşağıdaki formülü yazın:

=VLOOKUP(B7;Sheet1!$B$4:$H$1003;2;0)

(Türkçe: =DÜŞEYARA(B7;Sayfa1!$B$4:$H$1003;2;0) )

Bu formülün yazılı açıklaması şu şekildedir:

B7 hücresindeki değeri Sheet1 sayfasında B4:H1003 ile sınırlı alanda ara ve B kolonundan itibaren sola doğru 2. kolondan aynı satırdaki değeri getir.

Buna göre Excel aşağıdaki şekilde davranacak:

  • Sheet1 sayfasında B4:H1003 aralığına bakacak
  • En soldaki B kolonunda TR20127973 değerini (mevcut sayfanın B7 hücresindeki değer) arayacak
  • B kolonunda TR20127973 değerini bulduğunda B4:H1003 aralığının ikinci sütununda aynı satırdaki değeri alacak.
  • Eğer B kolonunda TR20127973 değerini bulamazsa #N/A (bulunamadı)hatası verecek.

Artık bu formülü aşağıya doğru kopyalayarak elinizdeki bütün satış kodlarını müşteri kodları ile eşleştirebilirsiniz. Burda unutulmaması gereken nokta $ işaretlerini kullanarak örnekteki gibi aralıkları sabitlemektir. Aksi takdirde fonksiyondaki aralıklar fonksiyon ile beraber aşağıya doğru kayarak ilerleyecek ve bu durum sonuçlarınızı etkileyecektir.

Başka örneklerle de Vlookup fonsiyonu ile ilgili alıştırma yapmanızı öneririm. İlk bakışta zor olsa da bir kere kavradıktan sonra en çok kullanacağınız fonksiyonlardan birisi olacaktır.

You may also like...

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.